Exchange 2010 Server Public Folder Database was not found.

Today I wanted to add another CAS/HUB Server to my environment and encountered a small error which can be fixed with running a command from the EMS.

When I tried to install the CAS role it gave this error:

Action “Update” could not be performed on the object ‘Default Offline Address List’
Error: Exchange server “PF database” was not found. Please make sure you typed the name correctly.

So I dismounted and mounted the PF database and still it didn’t fix the problem. After trying to make changes to the OAB it gave this error as well:

PF error

Coming from an Exchange 2003 environment when Exchange 2003 was decommissioned the server was actually looking for a name rather than the DB.

In the EMS I ran the following command:

Move-OfflineAddressBook -Identity “Default Offline Address list” -Server ServerName

Upon going back to the EMC and now going to the properties of the OAB I was able to enable the stuff I wanted enabled. Then from the EMS I ran setup.com /roles:clientaccess and the installation went through without any issues.

Hope it helps.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s