SCCM 2012 SP1 Upgrade SQL Error

Today I ran the SP1 upgrade for SCCM 2012. The first thing you come across is that you need ADK installed for SP1. The download is around 4GB, the first error I came across was when ADK was about 61% done, it failed with an error, user not currently allocated.

I cancelled the setup and moved the machine to a Container in AD that had no policies. Rebooted the machine and ran ADK install again. This time it succeeded.

Next error I got was that SQL needed to be on a static port. Upon opening SQL Configuration I got the following error:

SQLServerConfigerror

 

Seems like a bug in SQL though…To fix this open up an elevated prompt and type in the following:

mofcomp.exe “C:\Program Files (x86)\Microsoft SQL Server\100\Shared\sqlmgmproviderxpsp2up.mof”

After running this I was able to open SQL Configuration and enable TCP for that selected instance.

Hope it helps.

Advertisements

DPM 2012 Error ID 53

Today I installed a new DPM 2012 server. The installation went through fine and all backups were running well until the upgrade to SP1. Seems like a small bug as all my replica’s were inconsistent after applying the upgrade.

I uninstalled the DPM Agent, rebooted the DPM server plus the server where the Agent was installed and nothing.

Digging a bit deeper I came across this error: ID 53 – The service did not respond to the start or control request in a timely fashion (0x800t041D). I also checked the event log and no VSS writer information was being logged, DPM was saying it was running but nothing was actually happening.

Copied VssRequestor.dll from any of the servers that had the Agent installed to the DPM server (“C:\Program Files\Microsoft System Center 2012\DPM\DPM\bin\VssRequestor.dll”)

I then ran a consistency check and voila backups were back in progress.

Hope it helps.

Exchange 2010 SP3 Event ID Warning 10001

Today out of the blue I started getting the following warning on one of my Exchange Servers:

Mailbox cleanup could not completely remove the mailbox for user following mailbox removal. Encountered error 0xfffffae8. Should this message continue to persist for the same mailbox, it may be indicative of a problem that requires further investigation.

So no mailbox moves or removals have been done in about 8 months but to clear the warning from logging in event viewer every minute is to just dismount the database and  mount it again.

The warnings will be gone, maybe a bug of some sorts?

Hope it helps.