Event ID 14584 – LS Protocol Stack – Connection attempt to at least one service in a pool failed.

I have seen the warning/error below logged on my Lync Servers:

  • “Connection attempts to the following services have failed. Another attempt will be made for each service every 10 minutes.
    Service Address: 192.168.1.10:444; Pool FQDN: LyncPool1.domain.com; Down Time: 0:15
    Service Address: 192.168.1.10:5061; Pool FQDN: LyncPool1.domain.com; Down Time: 0:14

    Cause: The specified service(s) are unavailable.
    Resolution:
    Check the servers in the pool(s) on which the service(s) are installed.”

From what I have seen these have no impact on the server. My servers are fully patched and up-to-date.

Hope it helps.

LS Server Error 12308 (1000)

Checking the CS-Replication status I noticed one of my servers was not replicating, upon investigation the Front-End service wasn’t started, after starting it the following error was thrown:

  • A component could not be started. The service has to stop.

    Component: Live Communications User Services Error code: C3EE7A08!_HRX! (ES_E_FAILED_TO_CONNECT_TO_LOCAL_BACKEND!_HRM!)

Looks like the CS-Database wasn’t installed correctly or not all at.

Solution:

Open up Topology builder and right click on your server or click the actions menu and then select “Install Database”

After this the front-end service should start.

Hope it helps.

Lync Server Front End: Lost connection to the Web Conferencing Edge Server

Looking through the event log I stumbled across these 3 errors, logged at the same time every 5 min, after a reboot, every 15 min:

  • Event ID 41024 – Lost connection to all Web Conferencing Edge Services
  • Event ID 41024 – Lost connection to the Web Conferencing Edge Server
  • Event ID 41025 – Connection to the Web Conferencing Edge Server has been restored

Solution:

Disable IPv6 on the Front End server. You should disable it in the registry. Don’t forget to reboot after you make this change. Here is the MS KB article how to do this via the registry: http://support.microsoft.com/kb/929852

Hope it helps.